読者です 読者をやめる 読者になる 読者になる

iP4600をCUPSで使いたい

Linux Gentoo

Gentoo Linuxにcupsとgutenprintを入れたがcupsの管理画面でiP4600のドライバが出てこない。
どうもgutenprintのサイトを見ると5.2.4以上のバージョンが必要らしいが、今のportageでは5.1.4を利用するようになっているらしい。
とりあえず/usr/portage/net-print/gutenprintを見てみると5.2.6のebuildがあったので/etc/portage/package.keywordsを編集。

net-print/gutenprint ~x86

続いてemerge gutenprintすると5.2.6を取りに行くようになりました。

インストールが終わってcupsの管理画面に行くと今度はドライバのCanon PIXMA iP4600が出現したのでそいつを選択。
無事にテスト印刷までできましたとさ。